How to Use Composer for PHP Dependency Management

Composer is a popular PHP dependency manager.

Composer is installed by vpsmodel. However, because vpsmodel makes available multiple versions of PHP, you should invoke the correct Composer command for your app's version of PHP.

Each of the following commands calls Composer using a different PHP version:

Using PHP 7.0:

composer7.0-sp

Using PHP 7.1:

composer7.1-sp

Using PHP 7.2:

composer7.2-sp

Using PHP 7.3:

composer7.3-sp

Using PHP 7.4:

composer7.4-sp

For more information on using Composer, see the Composer getting started guide.